<?xml version="1.0" encoding="UTF-8"?><rss version="2.0"
	xmlns:content="http://purl.org/rss/1.0/modules/content/"
	xmlns:wfw="http://wellformedweb.org/CommentAPI/"
	xmlns:dc="http://purl.org/dc/elements/1.1/"
	xmlns:atom="http://www.w3.org/2005/Atom"
	xmlns:sy="http://purl.org/rss/1.0/modules/syndication/"
	xmlns:slash="http://purl.org/rss/1.0/modules/slash/"
	>

<channel>
	<title>APIPA &#8211; abow &#8211; how do you do IT</title>
	<atom:link href="https://abow.info/tag/apipa/feed/" rel="self" type="application/rss+xml" />
	<link>https://abow.info</link>
	<description>Alle möglichen Handkniffe, die ich mir so zusammentrage im Berufsalltag</description>
	<lastBuildDate>Mon, 05 Dec 2022 12:14:31 +0000</lastBuildDate>
	<language>de</language>
	<sy:updatePeriod>
	hourly	</sy:updatePeriod>
	<sy:updateFrequency>
	1	</sy:updateFrequency>
	

<image>
	<url>https://abow.info/wp-content/uploads/2026/06/cropped-favicon-512-32x32.png</url>
	<title>APIPA &#8211; abow &#8211; how do you do IT</title>
	<link>https://abow.info</link>
	<width>32</width>
	<height>32</height>
</image> 
	<item>
		<title>Ausbildung FISI // Grundlagen // IPv4-Adressklassen</title>
		<link>https://abow.info/ausbildung_fachinformatiker/grundlagen/ausbildung-fisi-grundlagen-ipv4-adressklassen/</link>
					<comments>https://abow.info/ausbildung_fachinformatiker/grundlagen/ausbildung-fisi-grundlagen-ipv4-adressklassen/#respond</comments>
		
		<dc:creator><![CDATA[Andi Bow]]></dc:creator>
		<pubDate>Wed, 28 Dec 2022 12:00:00 +0000</pubDate>
				<category><![CDATA[Grundlagen]]></category>
		<category><![CDATA[Adressklassen]]></category>
		<category><![CDATA[APIPA]]></category>
		<category><![CDATA[IPv4]]></category>
		<category><![CDATA[Private IP]]></category>
		<category><![CDATA[RFC]]></category>
		<guid isPermaLink="false">https://abow.info/?p=209</guid>

					<description><![CDATA[IPv4 wurde 1981 als RFC 791 veröffentlicht. Das IP (Internet Protocol) arbeitet auf der OSI-Schicht 3 (Vermittlungs-/Paketschicht) und dient zur Adressierung von Paketen.Es gibt die Unterscheidung von öffentlichen…]]></description>
										<content:encoded><![CDATA[
<p class="wp-block-paragraph"><strong>IPv4</strong> wurde 1981 als <strong>RFC 791</strong> veröffentlicht.</p>



<p class="wp-block-paragraph">Das <strong>IP</strong> (Internet Protocol) arbeitet auf der <strong>OSI-Schicht 3</strong> (Vermittlungs-/Paketschicht) und dient zur Adressierung von Paketen.<br>Es gibt die Unterscheidung von <strong>öffentlichen </strong>und <strong>privaten </strong>Klassen, hierbei werden die privaten nicht ins Internet geroutet.</p>



<p class="wp-block-paragraph">Jede IPv4 Adresse ist <strong>32 Bit</strong> lang und in <strong>vier Oktette</strong> eingeteilt. Theoretisch gibt es also maximal 4.294.967.296 (2<sup>32</sup>) eindeutige&nbsp;IPv4-Adressen.</p>



<p class="wp-block-paragraph">Aufbau einer IPV4-Adresse:</p>



<figure class="wp-block-table"><table><thead><tr><th>192.</th><th>168.</th><th>2.</th><th>1</th></tr></thead><tbody><tr><td>1. Oktett</td><td>2. Oktett</td><td>3. Oktett</td><td>3. Oktett</td></tr></tbody></table></figure>



<p class="wp-block-paragraph">Eine IP-Adresse enthält immer einen <strong>Netzanteil </strong>und einen <strong>Hostanteil</strong>. Der Netzanteil dient der Wegfindung, der Hostanteil der Zustellung zu einem bestimmten Computer im Zielnetz. Die Trennung von Netz- und Hostanteil erfolgt mit Hilfe der Subnetzmaske.</p>



<p class="wp-block-paragraph">Bestimmung von Netz- und Hostanteil:</p>



<figure class="wp-block-table"><table><tbody><tr><td>Subnetzmaske</td><td>255.</td><td>255.</td><td>255.</td><td>0</td></tr><tr><td>Netzanteil</td><td>192.</td><td>168.</td><td>2.</td><td>0</td></tr><tr><td>Hostanteil</td><td>0.</td><td>0.</td><td>0.</td><td>1</td></tr></tbody></table></figure>



<p class="wp-block-paragraph">Jedes Oktett besteht aus 8 Bit = 2<sup>8</sup> = 256, also einen Bereich von 0 &#8211; 255.</p>



<p class="wp-block-paragraph">Wobei die erste IP in einem Netz immer die <strong>Netzadresse </strong>ist und die letzte immer die <strong>Broadcastadresse</strong>.<br>Frei zu vergeben sind in einem Netzwerk/Subnetz also maximal die 1 &#8211; 254.</p>



<p class="wp-block-paragraph">Hier ein Schaubild für bestehende IPv4-Adressklassen.</p>



<figure class="wp-block-table is-style-stripes"><table><thead><tr><th>Klasse</th><th>IP-Bereich</th><th>Subnetzmaske</th><th>Netze</th><th>Adressen</th></tr></thead><tbody><tr><td>A</td><td>1-126.*.*.*</td><td>255.0.0.0</td><td>126</td><td>16.000.000</td></tr><tr><td>B</td><td>128-191.*.*.*</td><td>255.255.0.0</td><td>16.000</td><td>65.000</td></tr><tr><td>C</td><td>192-223.*.*.*</td><td>255.255.255.0</td><td>2.000.000</td><td>256</td></tr><tr><td></td><td></td><td></td><td></td><td></td></tr><tr><td>Privat A</td><td>10.*.*.*</td><td>255.0.0.0</td><td>1</td><td>16.000.000</td></tr><tr><td>Privat B</td><td>172.16.-172.31.*.*</td><td>255.255.0.0</td><td>16</td><td>65.000</td></tr><tr><td>Privat C</td><td>192.168.*.*</td><td>255.255.255.0</td><td>256</td><td>256</td></tr><tr><td></td><td></td><td></td><td></td><td></td></tr><tr><td>localhost</td><td>127.*.*.*</td><td>255.0.0.0</td><td>1</td><td>xxx</td></tr><tr><td>APIPA</td><td>169.254.*.*</td><td>255.255.0.0</td><td>1</td><td>65.000</td></tr></tbody></table></figure>



<p class="wp-block-paragraph"><strong>Wer ist für die Zuordnung von öffentlichen IP-Adressen zuständig?</strong> &#8211; Die IANA (Internet Assigned Numbers Authority).</p>



<p class="wp-block-paragraph"><strong>Was ist ein RFC? </strong>&#8211; Request for Comments (Spezifikationen, Vorschläge, Ideen und Richtlinien, die das Internet betreffen)</p>



<p class="wp-block-paragraph">Funfact RFC 1149 = Internet Protocol over Avian Carriers, mit Hilfe der Pakete mittels Brieftauben an den Empfänger gebracht wurden (war ein Aprilscherz).</p>



<p class="wp-block-paragraph">Zu dem Thema Subnetting mit IPv4 werde ich einen extra Beitrag schreiben und hier verlinken.<br>Ebenfalls werde ich IPv6 separat behandeln.</p>



<h2 class="wp-block-heading">Weitere interessante IP-Adressen</h2>



<p class="wp-block-paragraph"><strong>0.0.0.0/8</strong></p>



<p class="wp-block-paragraph">Die Adresse 0.0.0.0/32 bezeichnet den Host selbst. Diese Adresse darf nur als Quell-Adresse benutzt werden, zum Beispiel während der DHCP  bevor der Host eine Adresse erhalten hat. Definiert in RFC 5735, Seite 3.</p>



<p class="wp-block-paragraph"><strong>100.64.0.0/10</strong></p>



<p class="wp-block-paragraph">Adressbereich für Carrier Grade NAT (CGN, RFC 6264): Falls Internet Providern die IPv4-Adressen ausgehen, werden diese verteilt. (RFC 6598) </p>



<p class="wp-block-paragraph"><strong>127.0.0.0/8</strong></p>



<p class="wp-block-paragraph">Loopback-Adressen: Jedes an eine dieser Adressen geschickte Paket soll den Host nicht verlassen. Definiert in RFC 1700, Seite 4.</p>



<p class="wp-block-paragraph"><strong>169.254.0.0/16</strong></p>



<p class="wp-block-paragraph">Adressen für die automatische Konfiguration (APIPA, Zeroconf). Definiert in RFC 3927.</p>



<p class="wp-block-paragraph"><strong>192.0.0.0/24</strong></p>



<p class="wp-block-paragraph">Reserviert, wird bei Bedarf in das Vergabeverfahren übernommen. Definiert in RFC 5736.</p>



<p class="wp-block-paragraph"><strong>192.0.2.0/24</strong>, <strong>198.51.100.0/24</strong> , <strong>203.0.113.0/24</strong></p>



<p class="wp-block-paragraph">Reserviert als Beispieladressen in Dokumentationen (wie die Domain-Namen example.com und example.net aus RFC 2606). RFC 5737.</p>



<p class="wp-block-paragraph"><strong>192.88.99.0/24</strong></p>



<p class="wp-block-paragraph">Adressen für die Verbindung von IPv6-Netzwerken über IPv4 (&#8222;6to4 anycast address&#8220;), definiert in RFC 3068 reserviert.</p>



<p class="wp-block-paragraph"><strong>198.18.0.0/15</strong></p>



<p class="wp-block-paragraph">Adressen für Tests von Netzwerkkomponenten. Definiert in RFC 2544.</p>



<p class="wp-block-paragraph"><strong>224.0.0.0/4</strong></p>



<p class="wp-block-paragraph">Multicast zur Verteilung der Daten von einem Sender an mehrere, ausgewählte Empfänger. Die Nutzung der einzelnen Multicast-Adressen legt die IANA fest. Definiert in RFC 3171.</p>



<p class="wp-block-paragraph"><strong>240.0.0.0/4</strong></p>



<p class="wp-block-paragraph">Reserviert für die spätere Verwendung. Definiert im RFC 1112.</p>



<p class="wp-block-paragraph"><strong>255.255.255.255/32</strong></p>



<p class="wp-block-paragraph">Adresse für den &#8222;Limited Broadcast&#8220;. Sie darf nur als Zieladresse benutzt werden und Pakete mit dieser Adresse sollen nicht aus dem Netzwerk geroutet werden, aus dem sie stammen. Definiert in RFC 1700, Seite 4.</p>
]]></content:encoded>
					
					<wfw:commentRss>https://abow.info/ausbildung_fachinformatiker/grundlagen/ausbildung-fisi-grundlagen-ipv4-adressklassen/feed/</wfw:commentRss>
			<slash:comments>0</slash:comments>
		
		
			</item>
	</channel>
</rss>
